# Table of Content

1. Features ....................................................................................................................... 4  
   1.1 Cross Platform Availability ................................................................................ 4  
   1.2 Desktop Integration ............................................................................................. 4  
   1.3 Generating Output ............................................................................................... 4  
   1.4 XML Persistency ................................................................................................ 4  
2. Installation................................................................................................................... 4  
   2.1 System Requirements .......................................................................................... 4  
   2.2 Getting a JRE ...................................................................................................... 4  
   2.3 Download and Setup ........................................................................................... 5  
      2.3.1. Java WebStart ............................................................................................. 5  
      2.3.2. Windows Users ........................................................................................... 5  
      2.3.3. Other Operating Platforms .......................................................................... 5  
3. Getting Started Tutorial .............................................................................................. 6  
   3.1 Starting the Application ...................................................................................... 6  
      3.1.1. Java WebStart ............................................................................................. 6  
      3.1.2. Windows (XP) ............................................................................................ 7  
      3.1.3. Linux/Unix .................................................................................................. 7  
   3.2 First Startup ......................................................................................................... 7  
   3.3 Open File ............................................................................................................. 7  
   3.4 Charting Options ................................................................................................. 9  
   3.5 Change Parameters.............................................................................................. 9  
   3.6 Save Your Changes ............................................................................................. 9  
   3.7 Output ............................................................................................................... 10  
      3.7.1. Printing ...................................................................................................... 10  
      3.7.2. Exporting (Save Chart as …) ..................................................................... 10  
4. User Interface Reference........................................................................................... 12  
   4.1 The LMS2 User Interface ................................................................................. 12  
   4.2 Toolbar .............................................................................................................. 12  
      4.2.1. Document Manipulation Actions .............................................................. 12  
      4.2.2. Help Button ............................................................................................... 13  
      4.2.3. FIT Mode Chart Selection Actions ......................................................... 13  
      4.2.4. LSM Mode Chart Selection Actions ....................................................... 13  
   4.3 Menu bar .......................................................................................................... 14  
      4.3.1. The File Menu ........................................................................................... 14  
      4.3.2. File Menu ................................................................................................. 14  
      4.3.3. Edit Menu ................................................................................................. 14
1. Features

1.1 Cross Platform Availability
In 1994 the FIT and LSM software programs were implemented in FORTRAN and where targeted for the DOS/Windows platform of that time. By reimplementing the applications in Java/Swing we've added a up to date user interface (utilizing the Swing widget set) and make LSM2 available - without even recompiling it - for all OS platforms where a Java Standard Edition runtime is available, including Windows (W2K, XP, Vista), Mac OS and Linux/UNIX.

1.2 Desktop Integration
Assuming that today many users already have their data in Microsoft Excel documents, LSM2 supports copy/paste this data from Excel to LSM2 directly (both directions).

1.3 Generating Output
Basically there are two options available for generation high resolution output - either you use a printer driver in conjunction with the LSM2 application's printing option, or you choose one of the available chart exporting options. For now LSM2 can create PNG, WMF, EPS, PDF, SVG and SWF files.
Generating output is covered in more detail in the "Output Options" section of the user guide.

1.4 XML Persistency
LSM2 used XML files to store data. So LSM2's data is accessible for a broad range of XML parsing tools.

2. Installation

2.1 System Requirements
Because LSM2 is written entirely in Java, it can be used on any platform that supports Java (Standard Edition). We have tested it on Windows 2000/XP/7 , Linux (Ubuntu distribution) and Solaris.
To use LSM2, you will need at least 64 MB RAM (256 recommended) and about 5 MB free space on your hard drive. In addition, you must have a Java Runtime Environment (JRE) v 1.6 or later (as of August 2011 JRE 1.6 Update 26 is recommended). This will require another 50 MB free space on your hard drive.

2.2 Getting a JRE

  Look for "Java Runtime Environment (JRE) ... " and click to download the Java
Runtime Environment.
You do not need the full SDK. If you do have a contemporary JDK already installed, you can of course use it.

- **Mac OS X users**: Java support is built into the OS; if you are running 10.2.x (Jaguar), you should run Software Update to upgrade to Java 1.6.0 if you haven't already.
- **other Unix / OS users**: Check with your OS vendor (e.g. OS vendor home page) how to upgrade to JRE 1.6.0 or newer - if it is not already available on your system.

### 2.3 Download and Setup

Go to our [download page](#) to get the LSM2 package for your operating system.

For **now** we provide a Java WebStart option link and an installer package for Windows users.

For other operating platforms (Mac, Linux/Unix, ...) we provide ZIP files which contain all of the necessary files to run LSM2 including sample files but excluding the JRE.

#### 2.3.1. Java WebStart

That's the simplest option. Go to our [download page](#) and click the blue WebStart button.

#### 2.3.2. Windows Users

Users of the MS Windows operating platform can either use the Java WebStart option (see above) or the windows installer executable. Please keep in mind, that you must have a contemporary java runtime environment installed on your computer in order to run LSM2.

1. Make sure you have a contemporary java RTE on your computer.
2. Download the installer executable from our [download page](#).
3. Run the installer executable.
4. Start LSM2. You'll find the startup icon at:

   \[\text{start}\rightarrow\text{All Programs}\rightarrow\text{IIASA}\rightarrow\text{IIASA Logistic Substitution Model II}\]

#### 2.3.3. Other Operating Platforms

1. Make sure you have a contemporary java RTE on your computer.
2. Download the Zip file from our [download page](#).
3. Extract the zip file to a convenient place.
4. Start LSM2. – In the lib subdirectory run \texttt{java -jar LSM2.jar}
5. (optional) create a launcher (icon) for running LSM2 from your desktop.
3. Getting Started Tutorial

This section provides a brief overview on how to use the LSM2 software. A more detailed description of all the toolbar and menu bar entries is given in section 4 – User Interface Reference. A step by step example on how to fit a LSM is presented in section 5 – Example – LSM.

The Getting Started tutorial section demonstrates:

- How to start the LSM2 application - taking into account various operating system environments,
- Open an existing LSM2 document,
- use basic charting options
- save your changes,
- and how to save your chart as a image file or send it to a printer.

3.1 Starting the Application

3.1.1. Java WebStart

For the first startup click the blue web start button on our download page. Later on you can either use this option again or - if you agreed to let web start create a desktop icon for you - use the desktop icon.

![WebStart Security Warning](image)

Figure 1 WebStart Security Warning

If you want to run LSM2, you have to choose the Run button; if you click the Cancel button, LSM2 will not start.

For those who want to know why this happens: We're using a so called self signed certificate, which is not signed by a trusted party.
3.1.2. Windows (XP)
To run LSM2, double-click on the "LSM2" icon on your desktop, which you can also find in your Start Menu under "Start > All Programs > IIASA > Logistic Substitution Model II".

3.1.3. Linux/Unix
In the LSM2 directory, type `./runLSM2.sh` to launch LSM2.

3.2 First Startup
LSM2 opens the last document you last opened or saved by default. If this is your first time running LSM2, the program will create a new document.

![Figure 2 LMS2 - 1st Startup - New File](image)

3.3 Open File
For now we do not enter data manually. Instead we open a file from the samples directories that you have got during installation.

To do so, click the document button in the toolbar or go to the File menu and select Open.
In the Open dialog, navigate to the LSM directory and select the "US_CarsEmissionControls.xml" document to follow this basic usage tutorial. Later on you are encouraged to explore the other examples on your own.

After clicking to Open button, LSM2 opens the file and you end up with this:
3.4 Charting Options
The toolbar (and the chart menu bar) provide a set of charting options. At this stage we recommend the user to click on the toolbar button and then continue to the right until you reach the toolbar button.
For a more detailed description of the available charting options, have a look at the user interface reference (section 4).

3.5 Change Parameters
The tabbed pane below the graphic provides a couple of tabs which can be used to change the model and graphics parameters. For the purpose of this tutorial we propose to go to the “Plot” tab and change e.g. the plot title, legend position and symbol sizes in order to get a first impression of how to change parameters.

3.6 Save Your Changes
To make your changes to the model persistent, press the toolbar button (or go to the File menu → Save as …) and provide a filename where to save your changed data.

E.g. use “US_CarsEmissionControls-Modified.xml” as file name – we do recommend not overwriting the original .xml file.
3.7 Output

Basically there are two options available for generation high resolution output - either you use the LSM2 application's printing option in conjunction with a printer driver, or you choose one of the available chart exporting options.

3.7.1. Printing

You can print a hard copy of the chart area by clicking the button in the toolbar or by going to the File menu and selecting Print. This opens the Page Setup dialog, then the Print dialog.

![Page Setup and Print dialogs](image)

Figure 3 Page Setup and Print dialogs

The "Adobe PDF" printer is - of course - only available for selection if installed (it does not come with the freely available "Adobe Reader" but with the Adobe Acrobat). Other options for creating PDF files include PDF-XChange and eDocPrinter PDF.

Creating high resolution plots by using a printer driver is by no means limited to PDF. You can e.g. use any Postscript printer driver and redirect the output to a file in order to generate postscript files.

There are (commercial) printer drivers for various bitmap formats available.

3.7.2. Exporting (Save Chart as ...)

To export the chart area for using it on a web page or another program like MS-Word or MS-PowerPoint (or their OpenOffice equivalents), go to the File menu and select Save Chart as .... LSM2 will open a standard file dialog where you can enter the name of the file.

For now (01-Mar-2008) LSM2 offers:

- PNG - Portable Network Graphics
- WMF - Windows Meta File
- EPS - Encapsulated Postscript
- PDF - Portable Document Format
• SVG - Scalable Vector Format  
• SWF - Flash Format  

PNG is a raster image format that can be used in web pages, Word documents and PowerPoint presentations.  
WMF, EPS, PDF, SVG and SWF are all vector based formats. Unfortunately for now WMF, EPS and SWF exports do not support transparency.  
The exported chart can thereafter be e.g. imported into MS Word (Insert ➔ Picture ➔ From file …). The example below was created by exporting to PNG.

![Figure 4 Imported PNG figure created by means of Save Chart as …](image-url)
4. User Interface Reference

4.1 The LMS2 User Interface

Figure 5 depicts the structure of the LSM2 user interface. Like in almost all applications nowadays we start with a menu bar at the very top accompanied by a toolbar – see the lavender marked area in the figure. The red rectangle highlights the data input and display area on the left hand side. The upper right hand part is marked in blue and shows the graphics preview area whereas the green rectangle depicts the model parameterization area on the lower right hand side. Finally there is a status bar area (in grey) on the very bottom of the window.

4.2 Toolbar

There are two variations of the toolbar, the first one is used for fitting growth models to single time series data sets in LSM2's "FIT mode", the second one for fitting a logistic substitution model to multi time series data sets in LSM2 "LSM mode". Both toolbar button sets share the document related actions button group which make up left hand side.

4.2.1. Document Manipulation Actions

- New
- Open
We do assume that users will be familiar with what is triggered by pressing one of the New, Open, Save or Print buttons. The Export button will start the "export to excel" procedure. The user will select an output file to which LSM2 will export data and model parameters - in MS Excel format.

4.2.2. Help Button

There is a help button located on the very right hand end of the toolbar. Clicking the help button opens the LSM2 applications about dialog. Here you can find the LSM2 version number (0.9.18 in the example shown below).

4.2.3. FIT Mode Chart Selection Actions

In FIT mode - which LSM2 is in when there is just a single time series in the data set - the toolbar offers four charting options:

- **data** - will show just the data points of the time series.
- **fit** - will show data points plus the logistic growth curve.
- **fit (log)** - same as fit, but in semi logarithmic scale.
- **fit (FP)** - same as fit, but using the Fisher-Pry transformation.

More charting options are available by means of the chart menu.

4.2.4. LSM Mode Chart Selection Actions

Here is the list of LSM2’s charting options for the LSM mode - the LSM mode is active, whenever there is more than one time series in a data set.

- **data** - will show just the data points of the time series.
- **market** - cumulative data.
- **share** - market shares (data points).
- **LSM** - logistic substitution model curves (including market share data points).
- **LSM (cum)** - logistic substitution model - cumulative market shares.
• **LSM (FP)** - logistic substitution model in Fisher-Pry transformation.
• **LSM (amount)** - logistic substitution model market shares times total market curve.
• **LSM (amount, log)** - same as LSM (amount), but in semi logarithmic scale.
• **LSM (amount, cum)** - same as LSM (amount) but in cumulative display.
• **LSM (amount, cum, log)** - same as LSM (amount, cum) but in semi logarithmic scale.

4.3 **Menu bar**

4.3.1. **The File Menu**

4.3.2. **File Menu**

4.3.3. **Edit Menu**
4.3.4. Chart Menu - FIT Mode

<table>
<thead>
<tr>
<th>Chart</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show data</td>
<td></td>
</tr>
<tr>
<td>Show logistic fit</td>
<td></td>
</tr>
<tr>
<td>Show logistic fit (log)</td>
<td></td>
</tr>
<tr>
<td>Show logistic fit (Fisher-Pry transform)</td>
<td></td>
</tr>
<tr>
<td>Show linear fit</td>
<td></td>
</tr>
<tr>
<td>Show exponential fit</td>
<td></td>
</tr>
<tr>
<td>Show Gompertz fit</td>
<td></td>
</tr>
<tr>
<td>Show Sharif-Kabir fit</td>
<td></td>
</tr>
<tr>
<td>Show Floyd fit</td>
<td></td>
</tr>
<tr>
<td>Show multiple fit</td>
<td></td>
</tr>
</tbody>
</table>

LSM2 - Chart Menu - FIT Mode

In FIT mode - which LSM2 is in when there is just a single time series in the data set - the chart menu offers these charting options:

- **Show data**
  will show just the data points of the time series.

- **Show logistic fit**
  will show data points plus the logistic growth curve.

- **Show logistic fit (log)**
  show logistic fit (and data points) - in semi logarithmic scale.

- **Show logistic fit (Fisher-Pry transform)**
  show logistic fit (and data points) but using the Fisher-Pry transformation.

- **Show Gompertz fit**
  will show data points plus the Gompertz growth curve (if LSM2 was able to find a fit).

- **Show Sharif-Kabir fit**
  will show data points plus the Sharif-Kabir growth curve (if LSM2 was able to find a fit).

- **Show Floyd fit**
  will show data points plus the Floyd growth curve (if LSM2 was able to find a fit).

- **Show multiple fit**
  will show data points plus the logistic, Gompertz, Sharif-Kabir and Floyd growth curves (for those models where LSM2 was able to find a fit).
4.3.5. Chart Menu - LSM Mode

<table>
<thead>
<tr>
<th>Chart Menu - LSM Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show data</td>
</tr>
<tr>
<td>Show market share</td>
</tr>
<tr>
<td>Show logistic substitution model (Fisher-Pry transform)</td>
</tr>
<tr>
<td>Show logistic substitution model (amount)</td>
</tr>
<tr>
<td>Show logistic substitution model (amount, log)</td>
</tr>
<tr>
<td>Show logistic substitution model (amount, cumulative)</td>
</tr>
<tr>
<td>Show logistic substitution model (amount, cumulative, log)</td>
</tr>
<tr>
<td>Show market (data)</td>
</tr>
</tbody>
</table>

LSM2 - Chart Menu - LSM Mode

Here is the list of LSM2's charting options for the LSM mode - the LSM mode is active, whenever there is more than one time series in a data set.

- **Show data**
  will show just the data points of the time series.
- **Show market share**
  market shares (data points).
- **Show logistic substitution model**
  logistic substitution model curves (including market share data points).
- **Show logistic substitution model (Fisher-Pry transform)**
  logistic substitution model - Fisher-Pry transformation.
- **Show logistic substitution model (amount)**
  logistic substitution model market shares times total market curve.
- **Show logistic substitution model (amount, log)**
  logistic substitution model market shares times total market curve - in semi logarithmic scale.
- **Show logistic substitution model (amount, cumulative)**
  logistic substitution model market shares times total market curve - cumulative.
- **Show logistic substitution model (amount, cumulative, log)**
  logistic substitution model market shares times total market curve - cumulative in semi logarithmic scale.

4.3.6. Help Menu

<table>
<thead>
<tr>
<th>Help Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Log messages …</td>
</tr>
<tr>
<td>About LSM 2</td>
</tr>
</tbody>
</table>

The Help menu offers two entries:

- **Log messages …**
  will open the log messages panel.
• **About LSM 2**
  will open LSM2 about box. There you can find the LSM2 version number.

4.4 **Data Input & Display**

4.5 **Model & Graphics Parameterization**

As you may remember, the LSM2 software distinguishes between two modes – the FIT mode (fitting a curve to a single data series), and the LSM mode (fitting a Logistic Substitution Model to a set of series). The set of tabs in the model and graphics parameterization area is controlled by this mode. Sections 4.5.1 (FIT mode) and 4.5.2 (LSM mode) describe the available options.

4.5.1. Model Parameters – FIT Mode

The model parameterization area of the LSM2 applications user interface (i.e. the tabbed pane on the lower right part of the LSM2 application window) offers five tabs, which you can use to customize your data set.

The five FIT mode tabs are – from left to right:

- **Info** - for references and comments
- **Plot** - Plot Properties
- **Series** - Series Properties
- **FitRange** - for setting the model estimation input ranges
- **Scenario** – for fixing one (out of the three) logistic function parameter
- **Fitpar** - for displaying model fitting (output) parameters.

The Info Tab – References & Comments

The text area of this tab provides space for your notes and comments – e.g. to keep track of your data source. Please keep in mind that you have to press the **Apply** button before you save your model to make your changes persistent.
The Plot Tab – Plot Properties

The Plot Properties panel allows you to edit:

- the plot title,
- the domain axis label,
- the value axis unit label,
- the domain axis display range (min, max, increment),
- set the legend position,
- decide whether or not data points will be displayed on the plot.

Please do not forget, that in order to make your changes on this panel visible (and available saving) you have to press the **Apply** button. If you do not press the **Apply** button your changes will be **lost**.

The Series Tab – Series Properties

When being in FIT mode, the series tab enables the user to rename the series name. Double click in the Name column to start editing the name and hit the enter key to finish editing or escape to cancel. (Changing the LSM type is disabled – and adding another data series would force LSM2 into LSM mode)
The FitRange Tab – Model Estimation Input

The FitRange tab provides the opportunity to select the range of data which will enter the estimation.

Range Syntax \([ a : b ]\) Specifies a range from \(a\) to \(b\) including \(a\) and \(b\). One of the limits \(a\) or \(b\) may be omitted; more than one range area may be specified. If there is no range given, it defaults to \([-\text{infinite} : +\text{infinite}]\).

Range Samples

\[1820:1870\] \[1899:\]
Includes values between 1820 and 1870 plus all values greater than 1899. Border values (1820, 1870, 1899) are included.

\[:1935\] \[1950:\]
Include all values up to and including 1935 plus all values starting from and including 1950.

The Scenario Tab – Fix Model Parameter input

The Scenario Tab provides an option to fix one (out of the three) parameter of the logistic function (saturation, mid point, delta T)

The FitPar Tab – Model Estimation Output

The FitPar tab shows the LSM2 curve fitting output parameters for the set of six curve models (Logistic, Gompertz, Sharif-Khabir, Floyd, Exponential and Linear). In the
screenshot above, LSM2 has found solutions for three of them (Logistic, Exponential and Linear models).

### 4.5.2. Model Parameters – LSM Mode

The model parameterization area of the LSM2 applications user interface (i.e. the tabbed pane on the lower right part of the LSM2 application window) offers eight tabs, which you can use to customize your LSM2 data set.

The eight LSM mode tabs are - from left to right:

- Info - for references and comments
- Plot - Plot Properties
- Series - Series Properties
- LsmRange - for setting the LSM model estimation input ranges
- Lsmpar - for displaying model fitting (output) parameters.
- Market - for selecting a model for the (total) market.
- FitRange (Market) - for setting model estimation input parameters.
- FitPar (Market) - for displaying market model fitting (output) parameters.

#### The Info Tab – References & Comments

<table>
<thead>
<tr>
<th>References &amp; Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source:</td>
</tr>
<tr>
<td>N. Makienovic, 1986.</td>
</tr>
<tr>
<td>The automobile road to technological change.</td>
</tr>
<tr>
<td>For data see also:</td>
</tr>
<tr>
<td><a href="http://www.iiasa.ac.at/~gruebler/Data/TechnologyAndGlobalChange/usacars.csv">http://www.iiasa.ac.at/~gruebler/Data/TechnologyAndGlobalChange/usacars.csv</a></td>
</tr>
</tbody>
</table>

The text area of this tab provides space for your notes and comments.

#### The Plot Tab – Plot Properties

<table>
<thead>
<tr>
<th>Plot Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title: US Car Market by Emission Control Systems</td>
</tr>
<tr>
<td>XMin: 1950</td>
</tr>
<tr>
<td>XMax: 2000</td>
</tr>
<tr>
<td>X Inc: 0.25</td>
</tr>
<tr>
<td>Legend Position:</td>
</tr>
<tr>
<td>display data points</td>
</tr>
<tr>
<td>Symbol size (1): 12</td>
</tr>
<tr>
<td>Symbol size (2): 10</td>
</tr>
</tbody>
</table>

The Plot Properties panel allows you to edit:

- the plot title,
- the domain axis label,
- the value axis unit label,
- the domain axis display range (min, max, increment),
- set the legend position,
- set the symbol sizes and
- decide whether or not data points will be displayed on the plot.

The Series Tab – Series Properties

When being in LSM mode, the series tab enables the user to reorder and rename series as well as to change a type of a series (from “Data” to “Scenario”). You may also add new series and set the parameters (Tm and delta T) of scenarios (i.e. series of type scenario).

**Series reordering:** to change the display order of a series you simply edit the first (“#”) column. E.g. in the example to make the “Catalytic converter” series to number 1 you change it’s number from 3 to 1 (double click in field to start editing; hit enter key to finalize editing or escape to cancel).

**Add Series:** In order to add a series to your data set, you have to enter a name in the last (empty) row. In the sample screenshot above this would be in row number 4.

**Change Data Type:** click in the third (LSM type) column and select the Scenario option form the dropdown menu which will show up.

**Scenario Parameter** (Tm, delta T): if the LSM Type of a series is set to “Scenario”, the Tm and delta T columns are editable.

LsmRange Tab – LSM Model Estimation Ranges Input

When being in LSM mode, the series tab enables the user to reorder and rename series as well as to change a type of a series (from “Data” to “Scenario”). You may also add new series and set the parameters (Tm and delta T) of scenarios (i.e. series of type scenario).

**Series reordering:** to change the display order of a series you simply edit the first (“#”) column. E.g. in the example to make the “Catalytic converter” series to number 1 you change it’s number from 3 to 1 (double click in field to start editing; hit enter key to finalize editing or escape to cancel).

**Add Series:** In order to add a series to your data set, you have to enter a name in the last (empty) row. In the sample screenshot above this would be in row number 4.

**Change Data Type:** click in the third (LSM type) column and select the Scenario option form the dropdown menu which will show up.

**Scenario Parameter** (Tm, delta T): if the LSM Type of a series is set to “Scenario”, the Tm and delta T columns are editable.
The LsmRange tab provides the opportunity to select the range of data which will enter the estimation.

Range Syntax \[ a : b \] Specifies a range from \( a \) to \( b \) including \( a \) and \( b \). One of the limits \( a \) or \( b \) may be omitted; more than one range area may be specified. If there is no range given, it defaults to \([ -\text{infinite} : +\text{infinite} \])

Range Samples

**[1820:1870] [1899:]**
Includes values between 1820 and 1870 plus all values greater than 1899. Border values (1820, 1870, 1899) are included.

**[1935] [1950:]**
Include all values up to and including 1935 plus all values starting from and including 1950.

LsmPar Tab – LSM Model Estimation Output

<table>
<thead>
<tr>
<th>Series</th>
<th>( T_m )</th>
<th>( d_f )</th>
<th>( c_1 )</th>
<th>( c_2 )</th>
<th>( T_m )</th>
<th>( d_f )</th>
</tr>
</thead>
<tbody>
<tr>
<td>First emission controls</td>
<td>1,903.025</td>
<td>-63.811</td>
<td>1,900</td>
<td></td>
<td>1,966.613</td>
<td>-11.85</td>
</tr>
<tr>
<td>Catalytic converter</td>
<td>1,900.654</td>
<td>11.36</td>
<td>2,000.25</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The LsmPar tab shows LSM model fitting (output) parameters, that is the parameters of the market shares of the technologies data series.

Market Tab – Market Model Parameter Input

The Market tab determines which kind of model or scenario is used to model the total market within the LSM. The user can choose among six types (Logistic, Linear, Exponential, Gompertz, Floyd and Sharif-Khabir) and whether to use software fitted parameters or a so called scenario – providing the curve parameters manually. The \( >> \) button helps to start developing a scenario by copying the estimated (software) to the scenario input fields (in case there are no fitted parameters available, the parameters of the logistic fit are used).

FitRange(Market) Tab – Market Model Estimation Range Input
The FitRange(Market) tab provides the opportunity to select the range of data which will enter the estimation of the market total. For the range input syntax see the description of the LsmRange tab above.

### FitPar(Market) Tab – Market Model Estimation Output

<table>
<thead>
<tr>
<th>Series</th>
<th>Logistic</th>
<th>Linear</th>
<th>Exponential</th>
<th>Gompertz</th>
<th>Floyd</th>
<th>Sharif-Khabir</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>[127,794]</td>
<td>[2,281]</td>
<td>[0.025]</td>
<td>[0.025]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Market</td>
<td>[1,063.757]</td>
<td>[-4,177.585]</td>
<td>[-15.718]</td>
<td>[-120,516.357]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>delta_T</td>
<td>[46.77]</td>
<td>[45.671]</td>
<td>[45.718]</td>
<td>[45.671]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>alpha</td>
<td>[16.626]</td>
<td>[45.671]</td>
<td>[45.718]</td>
<td>[45.671]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ObjFunc</td>
<td>[0.999]</td>
<td>[0.979]</td>
<td>[0.935]</td>
<td>[0.935]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R-square</td>
<td>[0.999]</td>
<td>[0.979]</td>
<td>[0.935]</td>
<td>[0.935]</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The FitPar(market) tab shows market model fitting (output) parameters. In the screenshot above, the model has found solutions for the Logistic, Linear, and Exponential model; it did not find solutions for Gompertz, Floyd and Sharif-Khabir models.

### 5. Example – LSM

This section provides a step by step example on how to fit a Logistic Substitution Model (LSM) to an existing market data set. The example covers all steps from arranging the data in a spreadsheet (MS Excel or OpenOffice Calc) to importing the model outputs into your report.

1. prepare data
2. import data into LSM2 (copy/paste)
3. parameterization (series sequence, plot properties, estimation ranges, …)
4. save your model
5. generate output figures

#### 5.1 Input Data Preparation

For this step by step example we will use a data set from Grübler 1998 which is available online at [http://www.iiasa.ac.at/~gruebler/Data/TechnologyAndGlobalChange/](http://www.iiasa.ac.at/~gruebler/Data/TechnologyAndGlobalChange/), in particular the [usa-cars.csv](http://www.iiasa.ac.at/~gruebler/Data/TechnologyAndGlobalChange/usa-cars.csv) comma separated data file.
After some careful reading the data description we decide to use columns [7], [8] and [2] – which is “no emission controls”, “first emission controls” and “catalytic converters” – as technologies for our logistic substitution market model. Before we can copy/paste our data into LSM2 we have to arrange it into a rectangular area, ensuring the time axis data being the leftmost column of this rectangle – see figure Figure 7 below.

Figure 7 input data prepared for copying to LSM2

### 5.2 Import Data (Copy/Paste)

After we have prepared the data using a spreadsheet we are ready to copy/paste it into the LSM2 application. Here’s the sequence of how to do it:

1. Before you begin to copy data, both applications must be running - the spreadsheet and the LSM2.
2. Go to spreadsheet and select the range you want to use as data.
3. Initiate the copy/paste action.
   You can do this by e.g. pressing Ctrl+C or by using the menu (Edit→Copy)  
4. Go to the LSM2 and paste the data. You do so by using the "Edit→Paste Data" menu entry.
Figure 8 shows LSM2 just after the “Paste Data” step. Now we try to fit a logistic substitution model (LSM). We press the LSM toolbar button (or use the menu “Chart→Show logistic substitution model”).

Figure 8 Imported data set – show Data

Figure 9 Imported data set – show LSM (wrong sequence)
5.3 Parameterization

Ups – this (Figure 9) looks really bad. Obviously there something has gone completely wrong. What is wrong in this case is the sequence of the time series. The following section demonstrates how to handle this issue.

5.3.1. Series Sequence

One important aspect of a logistic substitution model is the sequence of time series (or technologies). This aspect the software cannot handle – so the user has to get this right. (Of course in the case of our step by step example the “wrong sequence” in the excel spreadsheet has been set up on purpose – to show how to reshuffle time series in the LSM2 software package)

![Series Properties Table](image)

Figure 10 change series sequence – step 1

We go to the series tab and move the “no controls” technology in first place. We activate the “Series” tab and change the series number. To do so, we double click the “#” field of the “no control” series and change the value from 3 to 1 (see Figure 10 and Figure 11). To finalize the editing we press enter. Figure 12 shows the result of fixing the series sequence.

![Series Properties Table](image)

Figure 11 change series sequence – step 2
As we now have applied a change to our LSM model, let's make it persistent. We press the save button (on the toolbar) or use the menu (File → Save as…), enter a filename (e.g. “StepByStepEmissionControl” – see Figure below) and press the save button.

5.3.2. Notes and Comments
As a next step we want to add some info to our new LSM data model. We activate the “Info” tab (in the parameterization area of the user interface) and enter what the model is
about and where we’ve got the data from – see Figure 14 and Figure 15. To make the comments persistent, you have to

- press the Apply button and
- save the LSM model (see above)

**If you forget to press the Apply button, your comments will be lost!**

![Figure 14: References and Comments dialog – before edit](image)

![Figure 15: References and Comments dialog – after entering notes](image)

### 5.3.3. Plot Properties

When we created our LSM model (by copy / pasting data) the software created very generic labels for the plot as well as for the domain and the value axes. Now we will replace them with specific data and adjust the domain axis scaling as well.

We change

- the plot title (USA - Cars in Operation with Emission Controls),
- the Value axis label (“million cars”),
- the domain axis scaling (1950 … 2000) and the X axis plot increment (0.1).

See Figure 16 and Figure 17 as well as Figure 18 for the resulting changes.
### Figure 16: Plot Properties dialog – before changes

<table>
<thead>
<tr>
<th>Property</th>
<th>Before Changes</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Chart Title</td>
<td></td>
</tr>
<tr>
<td>Domain</td>
<td>year</td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>data</td>
<td></td>
</tr>
<tr>
<td>X Min</td>
<td>1965</td>
<td></td>
</tr>
<tr>
<td>X Max</td>
<td>1984</td>
<td></td>
</tr>
<tr>
<td>X Incr</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>Legend Position</td>
<td>X display data points</td>
<td></td>
</tr>
<tr>
<td>Symbol size (1)</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>Symbol size (2)</td>
<td>10</td>
<td></td>
</tr>
</tbody>
</table>

### Figure 17: Plot Properties dialog – after changes

<table>
<thead>
<tr>
<th>Property</th>
<th>After Changes</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>USA - Cars in Operation with Emission Controls</td>
<td></td>
</tr>
<tr>
<td>Domain</td>
<td>year</td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>million cars</td>
<td></td>
</tr>
<tr>
<td>X Min</td>
<td>1950</td>
<td></td>
</tr>
<tr>
<td>X Max</td>
<td>2000</td>
<td></td>
</tr>
<tr>
<td>X Incr</td>
<td>0.1</td>
<td></td>
</tr>
<tr>
<td>Legend Position</td>
<td>X display data points</td>
<td></td>
</tr>
<tr>
<td>Symbol size (1)</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>Symbol size (2)</td>
<td>10</td>
<td></td>
</tr>
</tbody>
</table>

### Figure 18: Example screenshot – after changing labels and scaling
5.3.4. Estimation Ranges

In the next step we try to improve our model by adjusting the estimation input ranges. We tell the model to use data points for the “no control” and “early control” technologies until 1972 and for the “catalytic converter” technology from 1975 onwards.

**Figure 19: Lsm Ranges dialog – before changes**

<table>
<thead>
<tr>
<th>Series</th>
<th>Range (input format: [a,b])</th>
</tr>
</thead>
<tbody>
<tr>
<td>no control</td>
<td></td>
</tr>
<tr>
<td>early control</td>
<td>[1.972]</td>
</tr>
<tr>
<td>catalytic converter</td>
<td>[1975:]</td>
</tr>
</tbody>
</table>

**Figure 20: Lsm Ranges dialog – before changes**

**Figure 21: LSM estimation range changes applied**
Figure 21 shows the resulting output of these changes. The selected “Lsmpar” tab displays the output of the model (Tm and delta T parameters) for the three technologies. Note that all technologies are found to have a characteristic time (Tm) of about 11 years and that the first technology fit is a decreasing (negative dT) whereas the others have an increasing curve fit.

5.3.5. Market Settings

After tweaking the market shares model part, now let us have a closer look on the total market part of out LSM. When we created the model (remember the copy/paste) the model for the total market growth was initially set to be a linear one. In order to change this in a first step we go select the “Fitpar (Market)” tab.

![Figure 22: Fitpar (Market) tab](image)

The table displayed tells us that the software has found solutions for the logistic, linear and exponential curves. Now we go to the “Market” tab (Figure 23).

![Figure 23: LSM amount, cumulative, linear market growth model](image)

We can select the logistic or exponential market growth models, use the buttons to get starting values for scenarios. I’ve finally decided that my personal favorite is a Gompertz scenario model (K=146, Tm=1958, dT=60) – see Figure 24 below.
5.4 Generating Figures

Basically there are two options available for generation high resolution output - either you use the LSM2 application's printing option in conjunction with a printer driver, or you choose one of the available chart exporting options.

In our example we will export the plot as displayed in Figure 24 above to PNG and import this figure into the user guide.

We use the menu (File → Save Chart as...) to initiate the export, type in a filename (us-cars) and press the save button.

The exported chart can thereafter be e.g. imported into MS Word (Insert → Picture → From file ...).

Figure 26 shows what you get when you import the PNG file into a word document.
Figure 26: Example figure – imported the PNG file we’ve exported before
6. Tips & Tricks

6.1 Changing the decimal separator

After installing LSM2, the software is configured to use a dot (.) as the decimal separator. If you want (or have to) change this – e.g. in order to make the copy/paste work properly – you can change the decimal separator to a comma (,). To make the change happen you have to edit the LSM2_config.xml configuration file which is located in your “user.home” directory – on my windows system this expands to C:\Documents and Settings\kolp (the USERPROFILE environment variable); on my (Ubuntu) Linux box the file is located in my home directory /home/kolp (the $HOME environment variable).

The log message panel does know where to find the file – see figure below. You can open it by clicking the “Log messages …” entry in the Help menu.

1. exit LSM2 (if running)
2. Use the text editor of your choice (notepad is fine) to change the <Locale> setting from US to DE (see figures Figure 28 (US) and Figure 29 (DE) respectively).
3. (re)start LSM2

```xml
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<Config>
  <Locale>US</Locale>
  <MarkerSize1>12.0</MarkerSize1>
  <MarkerSize2>10.0</MarkerSize2>
</Config>
```

Figure 28: LSM2 configuration file – using . (dot) as decimal separator

```xml
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<Config>
  <Locale>DE</Locale>
  <MarkerSize1>12.0</MarkerSize1>
  <MarkerSize2>10.0</MarkerSize2>
</Config>
```

Figure 29: LSM2 configuration file – using , (comma) as decimal separator